Удаление последнего слова в таблице Excel

Удаление последнего слова в Excel — это простая задача, выполнить которую можно при помощи приведенной ниже формулы, которая также поможет извлечь (копировать) последние слова в новую ячейку.

Удаление последнего слова в Excel

Для выполнения данной задачи потребуется использовать формулу:

=ЛЕВСИМВ(СЖПРОБЕЛЫ(A2);ПОИСК("`";ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A2);" ";"`";ДЛСТР(СЖПРОБЕЛЫ(A2))-ДЛСТР(ПОДСТАВИТЬ(СЖПРОБЕЛЫ(A2);" ";""))))-1)

Удаление последнего слова из ячейки в таблице Excel

Все готово, задача выполнена. Аналогично можно избавиться и от начальных значений.

Пример:

Извлечь последнее слова в Эксель

Чтобы скопировать эти данные в новую ячейку можно использовать конструкцию:

=ЕСЛИОШИБКА(ПРАВСИМВ(A2;ДЛСТР(A2)-НАЙТИ(«*»;ПОДСТАВИТЬ(A2;" ";"*";ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;" ";"")))));A2)

Извлечение последнего слова из ячейки в таблице Эксель

Если потребуется больше операций в данном направлении ознакомьтесь со статьей.

Пример:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (5 оценок, среднее: 5,00 из 5)
Загрузка...