Извлечение слов из ячейки в таблице Excel

Извлечение слов из ячейки в таблице Excel — это простая задача, позволяющая получить первое или последнего слова из текста.

Извлечение первого слова из текста

Для того, чтобы выполнить эту задачу можно при помощи формулы:

=ЛЕВСИМВ(A2;НАЙТИ("*";ПОДСТАВИТЬ(A2;" ";"*";1)))

Извлечение первого слова из ячейки Excel

Важно! Последняя цифра 1 отвечает за количество слов, которое будет скопированы, поэтому заменив ее, например, на 3 можно получить первых 3 значения.

Пример для трех.

=ЛЕВСИМВ(A2;НАЙТИ("*";ПОДСТАВИТЬ(A2;" ";"*";3)))

Извлечение первых трех слов из таблицы Excel

Пример:

Копирование последнего слова

Решение заключается в использовании конструкции:

=ЕСЛИОШИБКА(ПРАВСИМВ(A2;ДЛСТР(A2)-НАЙТИ("*";ПОДСТАВИТЬ(A2;" ";"*";ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;" ";"")))));A2)

Извлечение последнего слова из ячейки Эксель

Данная конструкция работает без модификации и изменить ее нельзя.

Пример:

Извлечение n-го слова из ячейки

Получить n-е слово из текста можно при помощи этой формулы (в примере используется 3):

=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";ДЛСТР(A1)));ДЛСТР(A1)*(Number-1)+1;ДЛСТР(A1)))

Где Number — это число, отвечающее за номер.

Извлечение третьего слова из ячейки Excel

Пример №2 для 4-го

=СЖПРОБЕЛЫ(ПСТР(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";ДЛСТР(A1)));ДЛСТР(A1)*(4-1)+1;ДЛСТР(A1)))

Извлечение четвертого слова из ячейки Excel

Пример:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (5 оценок, среднее: 5,00 из 5)
Загрузка...