Как выполнить действие в каждой N-ой строке в Excel: пошаговая инструкция

Функция строка в Excel позволяет возвращать номер строки, что позволяет решать более сложные задачи, например, выполнение операций в каждой третьей или 5-й строке.

Инструкция функции СТРОКА в Excel

Для того, чтобы узнать номер строки можно использовать следующую формулу:

=СРОКА(B4)

Функция СТРОКА в Excel

Таким образом указав ячейку, например, N128 она вернет лишь вторую часть, те 128.

Примеры использования в более сложных формулах

Выполнить действие, например, умножить на 55 в каждой пятой строке также понадобиться данная функция:

=ЕСЛИ(ОСТАТ(СТРОКА(A1);5)=0;A1*55;A1)

Применение функции СТРОКА в Эксель в более сложных формулах

Все готово.

Подписывайтесь на наш канал в Яндекс.Дзен

Подписывайтесь на наши социальные сети

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (2 оценок, среднее: 5,00 из 5)
Загрузка...